[TC] Gaming Forums

Full Version: Car randomly shifts to neutral?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey guys,

Bit of a bum here.. Really wanna keep playing LFS, but I have found no trace as to the cause of my problem: the game keeps randomly shifting to neutral, even when just on the accelerator and pressing no buttons. It's completely random, no pattern, and not when any buttons are pressed. It just does it..

I've checked to see if there are any binds for a straight to neutral action, but there aren't any, and I have no buttons or anything / settings that would do this.

I'm using a G29, and it only does it when driving a car with an H Shifter, it seems that Semi-auto (XFR etc) vehicles have no issues.

Has anyone had this problem?

Pls help!

Cheers,

Quattro
Seems like your shifter "forgets" that a gear is engaged, as if the button wasn't pressed any more. So it's most likely a hardware issue more than a software one.

You could try reinstalling the Logitech software, but if the problem persists then you most likely have a faulty shifter.
Administrator Message by: BP

Thread Move: Live For Speed Area -> Tech Support
You said at cars with an H shifter, but do you actually drive with h-shifter?
Sorry BP, my bad!

I was thinking it's potentially a hardware issue.

Yes Chuck, I do drive with the H-Shifter and the clutch.

It's odd though, as it's only doing it in LFS.
Got a kind of related issue. My LFS sometimes totally randomly shifts down several gears. With KS and even with autogears on(yes, nub), but in manual too. Mostly in XFR but other cars aswell. Doesnt make a single bit sense and I think its not even possible to shift down so fast by accident as options->"gear shift debounce" prevents several fast buttonpresses in a row. Still i would try to increase that.
Could be that your problem is related to mine's. I have it occasionally that I end up in gear one although I wanted to shift from 3rd to 4th. But I know the reason of that. I'm using automatic transmission but also press manual gears every now and then.
So when LFS automatic switches from 3rd to 4th, it simulates a H shifter and goes to neutral for a fraction of a second. So, if I happen to press upshift in that situation, it goes from neutral to 1st gear. The rear wheel usually loose traction and I spin outWink

However, I don't think that's related to the OP.
My H shifter falls into neutral a lot but it's simply because it's broken after years of abuse. Could it be hardware problem with your shifter?
There's no physical movement, that's what I don't understand. It's nothing physical that's making it change gear as such.

I'll have another look at my gear shift settings but I don't think it'll be that. Sad
(2016-09-04 13:02)Quattro10V Wrote: [ -> ]There's no physical movement, that's what I don't understand. It's nothing physical that's making it change gear as such.

I'll have another look at my gear shift settings but I don't think it'll be that. Sad

There's a microswitch at the end of each shift gate, which the lever activates when it's in position. In the end, they are very precise. It doesn't require visible movement if there's a fault at the switches.

To me it would seem like the signal goes from 1 to 0 and back to 1 in an instant, potentially so fast that other games don't either even register it or they're just more lenient with their shifting mechanics. It gets rather complicated and unnecessarily long-winded to explain at that point.
It would certainly seem that was it sometimes spasms out and flicks between gears so fast. It did it once in another game, but then didn't do it again.

Thank you for the explanation. Is it worth me messing around with the gearshift debounce or whatever it's called? That way there's a delay and it can't process it as such?
Reference URL's