[TC] Gaming Forums

Full Version: G29 Shifter Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My G29 shifter has been working fine since I've bought it. I loaded up LFS to play earlier and whenever I tried to shift it would only select 5th gear regardless of what gear I put the shifter into. 5th gear will stay engaged and I can see in the LFS controls that the 5th gear button is constantly being pressed. I've tried re-binding the controls but this did not work.

Anybody know a fix or is it likely to be a hardware issue?
(2017-08-07 14:43)tomliamkins Wrote: [ -> ]the 5th gear button is constantly being pressed

Is this even when everything is unbinded or just in any gear?
(2017-08-07 15:22)Jack Wrote: [ -> ]
(2017-08-07 14:43)tomliamkins Wrote: [ -> ]the 5th gear button is constantly being pressed

Is this even when everything is unbinded or just in any gear?

Even with everything unbinded. I think it is Button 17, its constantly being pressed.
Sounds hardware issue then. You tried it in any other games? What is LGS saying?
Thought I'd provide an update if anybody even cares.

I contacted Logitech on 7th August to make a warranty claim on my Driving Force Shifter. The claim was approved and a new shifter was sent to me. When the shifter arrived I set it up alongside my wheel and opened LFS. To my surprise the issue was still there, meaning it was an issue with the connector on my G29. I contacted Logitech again on 15th August about my G29 and as of today (17th August) a new G29 has been shipped and I don't have to return the shifter they sent me!
Try reinstall software and drivers?
Reference URL's